Follow

Jira Integration Error : Invalid Integration System version or Version not supported

Who should face this error:

All JIRA Software cloud/On-prem users, who have integrated QMetry with JIRA would get an error "Invalid Integration System version or version not supported" while saving the integration.

Pre-requisite:

  • Make sure to check JIRA version.
    • If your JIRA is cloud: Set System Version as Cloud.
    • If your JIRA is Server/On-Prem: Set System Version as per the drop down versions.

 

Step 1: On your machine browser


Step 2: On QMetry Server

  • Ping JIRA URL and check if you get the response. 
  • If you get a response, Step 2 is successful. Move to Step 3. 
  • On failure: Connect with your IT to open the firewall.


Step 3 : Modify Payara (JVM) Settings (Refer Attached Screenshot)

  • Launch web browser and Login to Administration Console: http://<your-server-ip>:4848
  • Go to Configurations > server-config > JVM Settings > JVM Options
  • Add the parameter : -Dhttps.protocols=TLSv1,TLSv1.2,SSLv3 as shown below
  • Restart Payara Services
    • payara41/bin/asadmin stop-domain
    • payara41/bin/asadmin start-domain
  • Try to add integration again.

 

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk